Go Back  HuntingNet.com Forums > Firearms Forum > Black Powder
209's sticking in Mountaineer >

209's sticking in Mountaineer

Black Powder Ask opinions of other hunters on new technology, gear, and the methods of blackpowder hunting.

209's sticking in Mountaineer

Old 01-02-2016, 05:48 AM
  #1  
Typical Buck
Thread Starter
 
Join Date: Dec 2008
Location:
Posts: 818
Default 209's sticking in Mountaineer

Hey guys its been a while since I have been on here, but I know I will get good answers so I'm asking for some help. All of a sudden my Win 209 primers are sticking in the flash channel of my Mountaineer. Same loads with Blackhorn that I have always used but now the primer is sticking. It is the same that I have always used and I have had this gun since about the day they came out? Load info is the same 110 grains of Blackhorn, a Win 209 primer, and I'm switching between a 300 grain Lehigh, a 275 grain Lehigh and a 290 grain Barnes. Just not sure why all of a sudden they would stick and not eject? Any insight would be great!! Thanks in advance.
onetohunt is offline  
Old 01-02-2016, 06:08 AM
  #2  
Giant Nontypical
 
Join Date: Nov 2005
Posts: 6,585
Default

Originally Posted by onetohunt View Post
Hey guys its been a while since I have been on here, but I know I will get good answers so I'm asking for some help. All of a sudden my Win 209 primers are sticking in the flash channel of my Mountaineer. Same loads with Blackhorn that I have always used but now the primer is sticking. It is the same that I have always used and I have had this gun since about the day they came out? Load info is the same 110 grains of Blackhorn, a Win 209 primer, and I'm switching between a 300 grain Lehigh, a 275 grain Lehigh and a 290 grain Barnes. Just not sure why all of a sudden they would stick and not eject? Any insight would be great!! Thanks in advance.
Since then did not stick in the first place I would suggest you start by measuring the flash hole. When it gets to large the extra pressure on the 209 can cause it to stick.
lemoyne is offline  
Old 01-02-2016, 06:16 AM
  #3  
Nontypical Buck
 
WV Hunter's Avatar
 
Join Date: Feb 2003
Location: Virginia / West Virginia
Posts: 4,906
Default

That is my thought too. Possibly your breech plug hole has eroded over time.

If that is the case, you can have it modified by RonLaughlin (member here) to have a removable vent liner installed. Then when it wears out you just change the vent liner and are good to go.
WV Hunter is offline  
Old 01-02-2016, 07:08 AM
  #4  
Giant Nontypical
 
Gm54-120's Avatar
 
Join Date: Mar 2010
Posts: 5,533
Default

Make sure the flash CHANNEL is clean with a 5/32 drill bit too. As the channel fills up so does pressure on the primer.

Gm54-120 is offline  
Old 01-02-2016, 07:14 AM
  #5  
Boone & Crockett
 
bronko22000's Avatar
 
Join Date: Jan 2004
Location: Eastern PA
Posts: 12,549
Default

Originally Posted by Gm54-120 View Post
Make sure the flash CHANNEL is clean with a 5/32 drill bit too. As the channel fills up so does pressure on the primer.

Most likely this is your problem if you haven't cleaned it in a while. And that carbon is tough to remove. YOu may need a 1/8" and a 9/64" bit first if your flash hole is extremely blocked.
bronko22000 is offline  
Old 01-02-2016, 04:03 PM
  #6  
Typical Buck
Thread Starter
 
Join Date: Dec 2008
Location:
Posts: 818
Default

Thanks guys for the info!!
onetohunt is offline  
Old 01-02-2016, 04:51 PM
  #7  
Nontypical Buck
 
Join Date: Mar 2009
Location: Saxonburg Pa
Posts: 3,906
Default

Originally Posted by onetohunt View Post
Thanks guys for the info!!
Let us know what you find out. I also think your plug is wore out.
Grouse45 is offline  
Old 01-02-2016, 07:25 PM
  #8  
Fork Horn
 
pooldoc's Avatar
 
Join Date: Jan 2013
Location: Opelousas,La
Posts: 131
Default

I had a similar issue with my Disc Extreme with bare primer breech plug. I used JB bore paste on a Q tip to polish (clean) the primer pocket and that solved the problem. CVS has it's own brand of tips for babies ears that have a bulb on the end that worked really well
pooldoc is offline  
Old 01-03-2016, 05:56 AM
  #9  
Typical Buck
Thread Starter
 
Join Date: Dec 2008
Location:
Posts: 818
Default

One thing I did fail to mention is, the primer gets stuck in the breech plug whenever I close the bolt also, it doesn't have to be fired to be stuck?
onetohunt is offline  
Old 01-03-2016, 06:02 AM
  #10  
Nontypical Buck
 
Join Date: Mar 2009
Location: Saxonburg Pa
Posts: 3,906
Default

Originally Posted by onetohunt View Post
One thing I did fail to mention is, the primer gets stuck in the breech plug whenever I close the bolt also, it doesn't have to be fired to be stuck?
Ok, so we're can I buy a BH209 plug for a Accura MR Muzzleloader?
Grouse45 is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.