Whitetail Deer Hunting Gain a better understanding of the World's most popular big game animal and the techniques that will help you become a better deer hunter.

Problems with OnX?

Old 07-13-2021, 07:30 AM
  #1  
Typical Buck
Thread Starter
 
hubby11's Avatar
 
Join Date: Apr 2009
Location: Clifton, VA
Posts: 908
Default Problems with OnX?

I have been using the OnX for a few years now and have been pretty happy. It helps a great deal with my planning of both hunts and fishing. I use OnX on both my phone and home computer to plot out waypoints, tracks to follow. The map download feature is great since most of my hunting and fishing areas have no cel coverage.

My problem is that the most recent update to the online (via my computer) website seems very glitchy. It has almost completely stalled my computer to the point that I cannot use it. The layers take forever to load and using the mouse for zooming in/out or moving the cursor around has the map jumping all over the place. My computer is not brand new by any means but I get around the 'net with no problem. Curious if anyone else has noticed this.

Thanks,
hubby11 is offline  
Old 07-14-2021, 05:11 AM
  #2  
Super Moderator
 
Bocajnala's Avatar
 
Join Date: Dec 2006
Location: Trumbull County, Ohio
Posts: 8,469
Default

I only use the app and it's running fine for me.

-Jake
Bocajnala is offline  
Old 07-14-2021, 06:40 AM
  #3  
Nontypical Buck
 
MudderChuck's Avatar
 
Join Date: Apr 2015
Location: Germany/Calif.
Posts: 2,556
Default

Might be a computer problem. If you have multiple copies of the same program running in Task Manager close them all and start over again. Reboot your computer. Install the free "Clean Master" app don't use any of the add ons (important), just the Junk Clean. Install the free version of Malwarebytes.
You may have to deinstall the Onx program and reload it.
No idea of your computer literacy so try the easy stuff first.

Last edited by MudderChuck; 07-14-2021 at 06:42 AM.
MudderChuck is offline  
Old 07-14-2021, 09:41 AM
  #4  
Typical Buck
Thread Starter
 
hubby11's Avatar
 
Join Date: Apr 2009
Location: Clifton, VA
Posts: 908
Default

Originally Posted by Bocajnala View Post
I only use the app and it's running fine for me.
-Jake
The app works great for me as well, it's just my computer that is bogged down. Thing is, I am starting to use my computer more and more for planning purposes. I put waypoints at access points and mark out specific trails and such.

Originally Posted by MudderChuck View Post
Might be a computer problem. If you have multiple copies of the same program running in Task Manager close them all and start over again. Reboot your computer. Install the free "Clean Master" app don't use any of the add ons (important), just the Junk Clean. Install the free version of Malwarebytes.
You may have to deinstall the Onx program and reload it.
No idea of your computer literacy so try the easy stuff first.
Thanks for the advice. I consider myself semi-computer literate. I have already cleared out my browsing/cache history (I use CCleaner fairly regularly) and I try to pare down the add-ons and such. I have also tried using different browsers - Chrome, Firefox, Edge - without any noticeable difference. It may just be I need to upgrade my computer as it is 5-6 years old, but I have not seen a need until now.
hubby11 is offline  
Old 07-14-2021, 09:56 AM
  #5  
Nontypical Buck
 
excalibur43's Avatar
 
Join Date: Feb 2006
Location: Licking County, Ohio
Posts: 1,189
Default

Originally Posted by Bocajnala View Post
I only use the app and it's running fine for me.

-Jake
Same here. I only use the app. Works fine.
excalibur43 is offline  
Old 07-14-2021, 01:16 PM
  #6  
Nontypical Buck
 
MudderChuck's Avatar
 
Join Date: Apr 2015
Location: Germany/Calif.
Posts: 2,556
Default

I know when the heat sink for my CPU gets plugged up with pollen and dust it really slows my computer down. The higher the temp the slower my CPU gets. A clean heat sink really makes a difference.
MudderChuck is offline  
Old 07-15-2021, 06:24 AM
  #7  
Typical Buck
Thread Starter
 
hubby11's Avatar
 
Join Date: Apr 2009
Location: Clifton, VA
Posts: 908
Default

Originally Posted by MudderChuck View Post
I know when the heat sink for my CPU gets plugged up with pollen and dust it really slows my computer down. The higher the temp the slower my CPU gets. A clean heat sink really makes a difference.
Nah, problem is either an old computer or the new webpage is bloated. OnX is actually being fairly responsive. I am in a dialoge with them and am sending them screenshots with the Javascript. Hopefully the issue will be resolved.

My reason for posting this was just to see if anyone else was having this issue on their computer (not phone).

Thanks,
hubby11 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.