Go Back  HuntingNet.com Forums > General Hunting Forums > Whitetail Deer Hunting
Rubs Everywhere...But No Scrapes? >

Rubs Everywhere...But No Scrapes?

Whitetail Deer Hunting Gain a better understanding of the World's most popular big game animal and the techniques that will help you become a better deer hunter.

Rubs Everywhere...But No Scrapes?

Old 11-18-2013, 03:05 PM
  #1  
Spike
Thread Starter
 
JasonL's Avatar
 
Join Date: Oct 2013
Location: Tennessee
Posts: 22
Talking Rubs Everywhere...But No Scrapes?

Hey guys, I live in Middle Tennessee. The rut is in full-swing here. I hunt some nice private land with hardwoods, and non-farmed open field. I killed a big 6pt last week, and he was really stinking. I am finding rubs everywhere. New ones pop-up almost every other day. Big trees, small trees, anything they can rub, they will! But I have not found a single scrape! I've walked along the edge of the field, all through th hardwoods, and haven't found a single one. Is this typical, or am I not looking in the right places?
JasonL is offline  
Old 11-18-2013, 03:12 PM
  #2  
Giant Nontypical
 
early in's Avatar
 
Join Date: Sep 2005
Location: Mont County, Pa
Posts: 7,368
Default

If they are rubbing the way you describe, then there's scrapes out there as well. You're just not seeing them.
early in is offline  
Old 11-18-2013, 03:16 PM
  #3  
Fork Horn
 
kenified06's Avatar
 
Join Date: Oct 2013
Location: Virginia
Posts: 114
Default

I dunno but here in SWVA where Im hunting the rut is picking up and im seeing a lot of bucks but not many rubs or scrapes myself. I'm haven't been looking for any though but usually notice some here and there. I wouldnt worry about it if ur seeing deer

Last edited by kenified06; 11-18-2013 at 03:19 PM.
kenified06 is offline  
Old 11-18-2013, 04:59 PM
  #4  
Nontypical Buck
 
SWThomas's Avatar
 
Join Date: Oct 2008
Location: Camp Lejeune, NC
Posts: 3,869
Default

Don't stress it man. Just hunt those rubs!
SWThomas is offline  
Old 11-19-2013, 02:15 AM
  #5  
Fork Horn
 
NEhomer's Avatar
 
Join Date: Nov 2013
Location: Western Massachusetts
Posts: 106
Default

I've got scrapes everywhere but no rubs!
NEhomer is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.