Go Back  HuntingNet.com Forums > Outdoor Gear > Trail Cameras
 i40 screen disapearing >

i40 screen disapearing

Trail Cameras Post your trail cam photos, reviews, tips, and suggestions here.

i40 screen disapearing

Old 10-22-2008, 12:57 PM
  #1  
Typical Buck
Thread Starter
 
patchholder's Avatar
 
Join Date: Jan 2005
Location: Minnesota
Posts: 576
Default i40 screen disapearing

you guys maybe heard of this I don't know but the top half of my setup screen is disapeared, plenty of battery life yet, 57%. I have ran it alot lower before, got the camera when they first came out.
patchholder is offline  
Old 10-22-2008, 08:15 PM
  #2  
Nontypical Buck
 
pnut's Avatar
 
Join Date: Sep 2008
Location: Missouri
Posts: 1,421
Default RE: i40 screen disapearing

Sounds like the lcd is starting to fail.
Have you contacted Moultrie about it?
pnut is offline  
Old 10-23-2008, 03:41 PM
  #3  
Fork Horn
 
Join Date: Sep 2006
Posts: 177
Default RE: i40 screen disapearing

mine does that to after a rain and usually comes back when the sun shines on it,I emailed moultrie because I don't want to send back right now but haven't heard anything.I just up arrow once to get to the delete screen and switch cards
habitat is offline  
Old 10-23-2008, 04:07 PM
  #4  
Nontypical Buck
 
TexasBowHunter's Avatar
 
Join Date: Mar 2008
Location: Texas
Posts: 2,363
Default RE: i40 screen disapearing

I have been using mine all year and haven't had anything like that happen yet.....It has been a great camera so far...I would definately contact moultree and see what they have to say...I know they have been good about repairing a couple of my buddies D-40's....
TexasBowHunter is offline  
Old 10-23-2008, 07:58 PM
  #5  
Nontypical Buck
 
npaden's Avatar
 
Join Date: Dec 2006
Location: Lubbock, Texas
Posts: 1,401
Default RE: i40 screen disapearing

Sounds like a pretty common problem with the I-40's. Mine ended up going completely out and I called them up and they had me send it in. Hopefully they will fix it instead of giving me a new 2008 because it sounds like the trigger speed went downhill on the 2008 models. Hopefully they will get it fixed and return it quickly as well since hunting season starts in 2 weeks!
npaden is offline  
Old 10-25-2008, 06:04 AM
  #6  
Nontypical Buck
 
CamoCop's Avatar
 
Join Date: Oct 2003
Location: Lake County, Florida
Posts: 3,313
Default RE: i40 screen disapearing

my Moultrie 3.1 has this issue. it happened after Tropical Storm Fay moved through our area. i can only read half of the display but it still takes good pic's. the only problem i've had with my I40 is the red wire in the battery compartment that is soddered to the battery contacts broke. i have to re sodder it.
CamoCop is offline  
Old 10-25-2008, 04:29 PM
  #7  
Nontypical Buck
 
drhntr178's Avatar
 
Join Date: Jan 2005
Location:
Posts: 1,118
Default RE: i40 screen disapearing

The 2008 I40's are crap. I purchased my first one in september. Before i even put it in the woods the LCD screen went bad. I exchanged if for a new one. Two weeks in the woods and the infrared flash quits working. Emailed Moultire and got no response. Called and they said theyre not aware of any problems....Bull****! Its all over every forum on the net. Returned that one and got a third one. After 3 weeks, the LCD screen on this one went out also. Camera is still working though, just cant adjust anything on it. this ones going back after deer season. Moultrie needs to get their act together
drhntr178 is offline  
Old 10-25-2008, 07:12 PM
  #8  
Typical Buck
Thread Starter
 
patchholder's Avatar
 
Join Date: Jan 2005
Location: Minnesota
Posts: 576
Default RE: i40 screen disapearing

the camera is probably close to 2 yrs old now is it worth sending in too have fixed, how much does this usaually cost and about how long does it usually take. Thanks!
patchholder is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
artie97
Turkey Hunting
1
03-12-2006 10:47 AM
coyote170
Technical Help
1
09-20-2005 08:43 PM
newman1
Technical Help
2
03-05-2005 07:11 PM
buckmastr229
Young Hunters
19
10-07-2004 07:23 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Quick Reply: i40 screen disapearing


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.