HuntingNet.com Forums

HuntingNet.com Forums (https://www.huntingnet.com/forum/)
-   Trail Cameras (https://www.huntingnet.com/forum/trail-cameras-84/)
-   -   Primos 35 Problems?? (https://www.huntingnet.com/forum/trail-cameras/347273-primos-35-problems.html)

brodyb51 07-26-2011 05:54 PM

Primos 35 Problems??
 
Anyone else having problems with their Primos 35? I have two of them and within a week of each other they both stopped taking still pics. It shows pics on the card but their is nothing there. I swapped cards and still nothing. The green light comes on when I step in front of it but it does not trigger the camera. The video mode still works so I am using that function in the woods right now. These cams are only about a year old. I was very pleased with them for the price but if they crash after a year then no thanks.

Stonewall308 07-27-2011 10:54 AM

I have the primos truthcam 60, and have had no problems yet.

Try sending them back to primos.

8 TINES 07-27-2011 03:49 PM

I have a truth cam 46 and mine did the same thing but turns out I had an ant infestation so took cam down blew out ants and it worked fine again and has been ever since

brodyb51 07-28-2011 05:53 PM

I sent an e-mail to Primos customer service and received a very quick reply. I need to give them some info. from the cameras and they are going to replace them.

Thought I would pass the word along in case others have this issue.

youngfart 07-28-2011 07:52 PM

Brody
Thanks for the heads up,I have 2 46's and have had great success so far with them. Good to know they are right on the problem though at Primos.
Rocky


All times are GMT -8. The time now is 08:18 PM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.