Go Back  HuntingNet.com Forums > Archery Forums > Technical
 Hoyt Vectrix Cable Serving Wear ????? >

Hoyt Vectrix Cable Serving Wear ?????

Technical Find or ask for all the information on setting up, tuning, and shooting your bow. If it's the technical side of archery, you'll find it here.

Hoyt Vectrix Cable Serving Wear ?????

Old 08-27-2008, 10:26 AM
  #1  
Thread Starter
 
Join Date: Aug 2008
Posts: 2
Default Hoyt Vectrix Cable Serving Wear ?????

I read a few posts on here about servings wearing really bad and fast on the
Hoyt Vectrix. I had the same problem last year when I purchased the bow.
On the bottom cam, where the cable bends, the serving is tearing really bad.
Now that I got my bow back out Ineed to fix the problem. My archery guy said
he has seen the problem a lot and he could re-serve the cable for me. I am just
wondering if this is the solution to my problem? Or is it a Cam Design problem ??
I really dont want to get new cables this year so I'm not sure how to go about
solving this. Any info will help.
I'm sure some of you have had this same dilema.
Thanks all.....
Hunter16066
hunter16066 is offline  
Old 08-27-2008, 10:53 AM
  #2  
Typical Buck
 
Mikey S.'s Avatar
 
Join Date: Feb 2003
Location: masontown pa USA
Posts: 851
Default RE: Hoyt Vectrix Cable Serving Wear ?????

I only had about 100 shots on my vectrix last year and changed strings and cables.....but I do that on all my bows.However I noticed no bad wear on my factory strings when I removed them. If you have a good shop nearby, have them check your cam timing and cam lean, chances are it needs some twists here and there to bring everything back in line if it's a year old. And yea, if they can re-serve that, have them do it......if they are good at it. It'll be ok.
Mikey S. is offline  
Old 09-01-2008, 11:03 AM
  #3  
 
Capt. Mark Bennett's Avatar
 
Join Date: Mar 2006
Location:
Posts: 80
Default RE: Hoyt Vectrix Cable Serving Wear ?????

I had the same problem on my Trykon after only 4 months shooting on the factory string, same thing bottom cam. I replaced it with a winners choice string and two years &6 months later it is still in perfect condition.
Capt. Mark Bennett is offline  
Old 09-01-2008, 12:13 PM
  #4  
Fork Horn
 
Join Date: Feb 2008
Posts: 217
Default RE: Hoyt Vectrix Cable Serving Wear ?????

I had this problem with my Vulcan I had the stock string/cable system on it and pretty much had used it up in less than 8 months. I have now put a Vapor Trail string /cable system on and although I have only had it for about 3 weeks I am noticing the difference already. Only time will tell the wear characteristics though.

AZHuntr is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Campo
Technical
1
11-13-2006 08:17 PM
Shootem up870
Bowhunting
2
02-05-2004 06:21 AM
nathanBA
Technical
4
10-17-2003 09:33 AM
Howler
Technical
10
10-09-2003 05:11 PM
Two Beards
Technical
4
02-11-2003 07:53 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Quick Reply: Hoyt Vectrix Cable Serving Wear ?????


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.